Wer keine Online-Anfragen wünscht, sollte das Kontaktformular schließen

Seien Sie gegrüßt. Bieten Sie auf ihrer Webseite im Bereich Kontakt auch ein Kontaktformular an? Zur allgemeinen Kontaktaufnahme oder evtl. auch zur Online-Terminvereinbarung? Versprechen Sie ihren Besuchern evtl. sogar, auf eingehende Anfragen zu reagieren? Wenn einer dieser Punkte auf Sie zutrifft und Sie ihren Besuchern tatsächlich auf eingehende Nachrichten bzw. Terminanfragen antworten, dann haben Sie [Weiterlesen…]

Wer viel misst, misst viel Mist

Im Falle dieses Artikels bezieht sich der Titel auf das Messen von Temperatur und relativer Luftfeuchtigkeit mit einem DHT22-Sensor (AM2302). Im Rahmen eines kleinen Wochenend-Projekts möchte ich mit Hilfe des genannten Sensors, der Open-Source-Plattform NodeMCU V3 und einem Raspberry Pi eine Raumklimaüberwachung für unsere Wohnung basteln. Der NodeMCU V3 mit aufgesetztem ESP8266 scheint dazu gut [Weiterlesen…]

RHEL 7: Wie stelle ich sicher, dass nur Pakete aus unterstützten Quellen installiert sind?

In diesem Artikel dokumentiere ich (vor allem für mich selbst), wie man ein System in einen Zustand versetzen kann, in dem ausschließlich RPM-Pakete aus Repositories (Repos) installiert sind, für die man kommerziellen Support erhält. Dazu gehe ich kurz auf den Hintergrund der Aufgabenstellung ein, bevor ich anschließend eine mögliche Lösung beschreibe. Die Hintergrundgeschichte Für meine [Weiterlesen…]

vSphere PowerCLI: Snapshots nach Namen suchen und löschen

In diesem Beitrag möchte ich kurz dokumentieren, wie vSphere Snapshots mit Hilfe der PowerCLI nach Namen gesucht und gelöscht werden können. Anwendungsfall Beruflich betreue ich mehrere vSphere-Cluster mit einigen hundert virtuellen Maschinen (VMs). Um diese VMs zu sichern, kommt eine Image-Backup-Software zum Einsatz. Diese erstellt zum Zeitpunkt der Sicherung von jeder VM einen Snapshot, sichert [Weiterlesen…]

mysql_upgrade – prüft und aktualisiert MySQL-Tabellen

Vergangenes Wochenende hat KOFREZO unseren Server von Ubuntu Trusty Tahr auf die aktuelle LTS-Version Xenial Xerus aktualisiert. Einhergehend mit dem Release-Upgrade wurde MySQL auf Version 5.7 aktualisiert. Beim ersten Versuch, ein Backup meiner Datenbank mit mysqldump zu erzeugen, wurde ich überraschend mit folgender Fehlermeldung konfrontiert: mysqldump: Couldn’t execute ‚SHOW VARIABLES LIKE ‚gtid\_mode“: Native table ‚performance_schema‘.’session_variables‘ [Weiterlesen…]

Import von iCal-Dateien in einen ownCloud-Kalender

Dieses Tutorial zeigt, wie Kalender bzw. Termine aus einer iCalendar-Datei (Abk. iCal; Dateiendung: .ics, .ifb, .iCal, .iFBf) in einen ownCloud-Kalender importiert werden können. Zur Erstellung des Tutorials habe ich das Vortragsprogramm der Chemnitzer Linux Tage 2017 genommen, welches als ICS-Datei bereitgestellt wurde. Die verwendete Datei ist am Ende des Tutorials angehängt, so dass man diese [Weiterlesen…]

Protokoll zum Ausfall eines Webdienstes nach der fehlgeschlagenen Erneuerung eines Let’s Encrypt Zertifikats

In diesem Beitrag werden die Ursache und der Verlauf der Störung protokolliert, welche die vorübergehende Nichterreichbarkeit einer Seafile[1. Seafile – Wikipedia]-Installation zur Folge hatte, welche ich für den Freifunk Lippe[2. Webpräsenz Freifunk Lippe] betreibe. Beschreibung der Umgebung Die Seafile-Installation wird ausführlich in „Installation von Seafile auf einem Ubuntu/Debian Server“ beschrieben. Die aktuelle Installation wurde wie [Weiterlesen…]

NGINX verweigert Neustart – [emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)

In diesem Artikel möchte ich einige Informationen zur NGINX-Fehlermeldung „[emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use)“ wiedergeben. Als ich heute Morgen die E-Mail-Reports meiner Server durchgesehen habe, fiel mir die Meldung ins Auge, dass auf einem meiner Server die NGINX-Konfiguration nicht erneut eingelesen werden konnte. Auch der Versuch eines manuellen Neustarts wurde [Weiterlesen…]

WordPress fordert zum Update Verbindungsinformationen (FTP-Zugangsdaten) an

Wie im letzten Beitrag geschildert, ist dieser Blog auf einen anderen Server umgezogen. Aktuell teste ich noch alle Funktionen und versuche, die gefundenen Fehler zu bereinigen. An dieser Stelle möchte ich mich auch schon einmal bei all denen bedanken, die mich auf Fehler aufmerksam gemacht haben. Heute wurde ich im Backend auf das WordPress-Update 4.7.1 [Weiterlesen…]

Jörg Kastning

26. Dezember 2016

Mein WordPress-Blog „My-IT-Brain“ ist bis auf Weiteres auf einen neuen Server umgezogen.

Die Migration verlief nahezu reibungslos. Es mussten lediglich ein paar Plugins entfernt werden, die auf dem neuen Server ihre Arbeit verweigerten.

Falls ihr beim Besuch meiner Seite auf Fehler stoßt bzw. Dinge entdeckt die nicht (mehr) funktionieren, freue ich mich, wenn ihr diese über das Kontaktformular meldet.

Frohe Weihnachten
Der Webmaster