T-Online Mediencenter in Ubuntu einbinden

Mit dem T-Online Mediencenter bietet die Telekom einen Cloudspeicherdienst mit 25GB
Speicherkapazität. Dieser Artikel schreibt wie man das Mediencenter als Datenspeicher in Ubuntu/Linux einhängen kann, um es komfortabel mit dem Dateimanager oder über die Shell nutzen zu können.

Wie viele andere Speicherdienste kann auch das Mediencenter über den Webbrowser
genutzt werden. Die Software zur Synchronisation und zum Zugriff gibt es jedoch nur für Windows. Ein Softwareclient für Linux ist auch nicht in Planung. Es besteht jedoch die Möglichkeit das Mediencenter mittels WebDAV in das lokale Dateisystem einzuhängen. Die folgende Anleitung beschreibt wie dies funktioniert.

Quelle: http://skripta.de/Davfs2.html

T-Online-Cloud (Mediencenter) unter Linux einbinden
===================================================

Anmerkung: Die folgende Kurzanleitung wurde aus verschiedenen 
aehnlich lautenden Online-Anleitungen zusammengestellt und getestet.
z.B.:
http://anderes-en.de/blog.php?mode=view&blog=11
http://blog.philippklaus.de/2010/04/mount-t-online-mediencenter-via-webdav/

Es wurden nur geringfuegige Aenderungen vorgenommen. 

=======================================================

Paket davfs2 installieren:

    * sudo apt-get install davfs2

Berechtigungen fuer den Benutzer (username = lokaler Linux-Anmeldename) setzen:

    * sudo chmod u+s /usr/sbin/mount.davfs
    * sudo usermod -a -G davfs2 username

Im Home-Verzeichnis den spaeteren Mountpoint (Verzeichnis) erstellen:

    * mkdir ~/Mediencenter

Jetzt zur fstab:

     * cd /etc
     * sudo nano fstab

und folgendes am Ende eintragen (username = lokaler Linux-Anmeldename):

     * # T-Online Mediencenter
     * https://webdav.mediencenter.t-online.de/ /home/username/Mediencenter davfs rw,noauto,user 0 0

Datei secrets erstellen und editieren 

     * cd ~
     * mkdir ~/.davfs2
     * touch ~/.davfs2/secrets
     * chmod 600 ~/.davfs2/secrets
     * nano ~/.davfs2/secrets

In die Datei ~/.davfs2/secrets folgendes eintragen (username = lokaler Anmeldename) und 
fuer anmeldung@t-online.de sowie password die T-Online-Zugangsdaten eintragen:

     * /home/username/Mediencenter anmeldung@t-online.de password

Dann die davfs2.conf kopieren und editieren:

     * cp /etc/davfs2/davfs2.conf ~/.davfs2/
     * nano ~/.davfs2/davfs2.conf

Die dort vorhanden Settings auf folgende Werte aendern und das # davor entfernen:

     * if_match_bug 1
     * use_locks 0
     * cache_size 1 # MiByte
     * table_size 4096
     * delay_upload 1
     * gui_optimize 1

Jetzt kann man mit mount ~/Mediencenter das Online-Verzeichnis einhaengen 
ohne Eingabe der Zugangsdaten.

29 Gedanken zu „T-Online Mediencenter in Ubuntu einbinden

  1. Tom

    Hallo und vielen Dank für die detaillierte Auflistung!

    Als Ubuntu-Anfänger habe ich sicher den ein oder anderen Fehler gemacht, daher würde mich interessieren, ob es für die folgende Fehlermeldung nach dem Mount-Versuch eine einfache Lösung gibt:

    Fehler: Fehler beim Holen der Informationen für Datei »/home/#user#/Mediencenter«: Der Socket ist nicht verbunden
    Bitte wählen Sie einen anderen Betrachter und versuchen Sie es erneut.

    Falls nicht, werde ich wohl besser nach jemandem suchen, der sich damit auskennt ;)

    Trotzdem vielen Dank für sachdienliche Hinweise,
    Tom

    Antworten
    1. Peter Misch

      Hallo,

      Diese Anleitung stammt von mir.
      Ich freue mich darüber, dass sie auch für andere nützlich ist.

      Zudeiner Frage:

      Ganz einfach: Du musst natürlich statt #user#
      DEINEN EIGENEN USERNAMEN (Login von ubuntu) eingeben.

      Gruss
      PMisch

      Antworten
  2. Thomas

    Hallo,

    nach Eingabe der Zeile
    cd /etc/fstab
    kommt bei mir die Fehlermeldung:
    bash: cd: /etc/fstab: Ist kein Verzeichnis
    Ich bin noch neu im Ubuntuland und würde mich über eure Hilfe freuen.
    Gruß.
    T

    Antworten
  3. Pingback: Cloud | Pearltrees

  4. Matthias

    Hallo Peter,

    vielen Dank für die detaillierte Anleitung. Hat bei mir auch Funktioniert. Wenn ich das Mediacenter mounte erscheint die Meldung:
    WARNING: gnome-keyring:: couldn’t connect to: /tmp/keyring-IzIkEg/pkcs11: Datei oder Verzeichnis nicht gefunden
    Es funktioniert aber trotzdem. Was hat das zu bedeuten ?
    Grüße
    Matthias

    Antworten
    1. JohnDoe Beitragsautor

      Hallo Matthias,

      zu deiner Meldung habe ich einen Beitrag im Forum von Ubuntuusers.de gefunden. Dort wurde offensichtliche eine Lösung gefunden. Schau doch mal hier.

      MfG
      Jörg

      Antworten
      1. Matthias

        Hallo Peter,

        danke jetzt geht alles. Ich mußte nur die Laufzeitumgebung GNome beim Starten laden , unter Einstellungen > Sitzung und Startverhalten ! kann man dort auch ein hacken setzten 1

        mfg

        Matthias

        Antworten
  5. Margit

    Hallo Peter,
    Mediencenter heist jetzt magentaCLoud.
    und obwohl angegeben ist das der Server WebDAV fähig sein soll bekomme ich immer die Meldung
    das Einhängen schlug fehl; der Server unterstützt WebDAV nicht
    und was jetzt ?
    mfg
    Margit

    Antworten
  6. Peter Misch

    Ach ja – nochwas:

    Im Ubuntu-Dateimanager (nautilus) lautet die Zeile in „Mit Server verbinden“:

    davs://webdav.mediencenter.t-online.de/

    davs://, nicht dav://

    Gruss
    Peter

    Antworten
  7. Stefan

    Bis hier war es eine tolle Anleitung,alles ohne Probleme.Aber dann das .Habe alle Daten überprüft.
    mount ~/Mediencenter /sbin/mount.davfs: das Einhängen schlug fehl;
    Legitmierung am Server fehlgeschlagen: Zurückgewiesene Basic-Aufforderung

    Und hier steht root root und nicht mein Name.
    -rw——- 1 root root 1393 Jun 5 17:35 /home/stefan/.local/share/recently-used.xbel.

    Gibt es eine Lösung?
    Danke

    Antworten
  8. dermaxem

    Habe die Anleitung fast 1zu1 auf einem PI mit Erfolg umgesetzt.
    Nur dort gibt es keinen Ordner „fstab“ sondern nur eine Datei „fstab“ und einen Ordern „fstab.d“.
    Ich habe die Datei fstab editiert und den https-Link hinzugefügt und es klappte.
    Zwar auch erst der zweite Anmeldeversuch, aber es ging dann wie beschrieben.

    Eine Frag dazu: Ich reboote den PI jede Nacht. Wie kann ich das automatisch mounten, da ich per Webcam dort dann Bilder ablegen möchte.

    Antworten
    1. Tronde

      Hallo,

      die Sache mit dem automatischen Einhängen nach einem Reboot ist nicht ganz so einfach zu bewerkstelligen.

      Damit beim Start versucht wird das Mediencenter einzuhängen, muss die Option „noauto“ durch „auto“ ersetzt werden. Das ist aber nur die halbe Miete.

      Du musst deinen Pi so konfigurieren, dass er das Netzwerkinterface startet, bevor er versucht das Dateisystem einzuhängen. Sonst könnte es passieren, dass der Mountversuch fehlschlägt. Leider kann ich dir nicht erklären, wie genau man das bewerkstelligt.

      Gruß
      Tronde

      Antworten
  9. Uli

    Das geht mit Networkmanager. Unter /etc/Networkmanager/dispatcher.d einfach ein ausführbares bash-Skript anlegen, das bei Parameter „start“ den mount ausführt und bei Parameter „stop“ eben den umount.

    Antworten
  10. dermaxem

    Habe ein Problem: Nach einem Neustart steht der PI auf der Console mit der Frage nach einem Benutzernamen für die Webdav-Verbindung. Wenn ich keinen eingeben möchten, soll ich „Enter“ eingeben. Wenn ich versuche mit Enter diesen Schritt zu überspringen, passiert nichts mehr. Dito beim Versuch einen Usernamen einzugeben. Für einen Unterstrich sehe ich nur komische Steuerzeichen. Irgendwie ist das Ding ncht mehr bootfähig. Kann man die SD-Karte unter Windows irgendwie mounten und dort dann die Konfiguration wieder „richten“? Oder muss ich das Ding neu aufsetzten?

    Antworten
  11. Uli

    Also neu aufsetzen ist doof. Unter Windows mounten ist auch doof, weil die meisten Editoren keine Unix-Zeilenenden machen, vielleicht geht das mit vi unter Windows. Mounten unter Windows geht aber auch nur, wenn Du kein ext-Dateisystem hast. Üblicherweise würde ich eine Linux-Boot-CD nehmen und die SD-Karte dann damit mounten. Ich kenne aber den Pi nicht, daher sind mir die üblichen Verfahren damit nicht so geläufig. Für Dein Kernproblem frage ich mich, warum du die Credentials nicht einfach in der secrets-Datei ablegst.

    Antworten
    1. dermaxem

      habe ich ja so gemacht und die Datei mit den Zugangsdaten auch angelegt. Er fragt beim Booten trotzdem. Evtl. habe ich was falsch gemacht oder was auch immer.
      Fakt: Ich bin selber schuld, das ich vorher kein Backup gemacht habe und kann nun zu sehen, wie ich es wieder ans laufen bekomme.

      Antworten
  12. dermaxem

    Hab nun ein Ubuntu unter VM im Windows laufen. Wie kann ich von dort die SD-Karte (des Raspi) im USB-Reader des PC (Host des VM) lesen/schreiben? im Linus dann unter /dev gucken? Oder muss ich das erst noch selber mounten? Ich bin da Neuling was Linux angeht.

    Antworten
    1. Tronde

      Das hängt zuerst einmal davon ab, womit du das Ubuntu virtualisiert hast. VMware? Virtualbox? Was benutzt du denn?

      Schau im Handbuch des Programms nach, mit dem du Ubuntu virtualisiert hast. Dort sollte es ein Kapitel geben, das erklärt, wie du USB-Sticks bzw. SD-Cards an den Gast weiterreichst. Häufig sind SD-Card-Reader ebenfalls an den USB-Bus angeschlossen und du kannst die Anweisungen aus dem entsprechenden Kapitel befolgen.

      Antworten
      1. dermaxem

        ich habe geschrieben, das es VM ist. Aber die Frage ist: Wie komme ich von dem in der VM gestarteten Ubuntu auf die SD_Karte? Muss ich da was mounten? Wie sehe ich alle gemounteten Devices? Wenn es schon gemountet ist, wie erkenne ich, welches davon die SD-Karte für den PI ist, bzw. da sind doch bestimmt verschiedene Partitionen auf dem Image für den PI. Welche davon enthält die Daten, die ich für eine Bereinigung brauche? (Oder ich setzt den PI einfach neu auf, das scheint schneller zu gehen als Stunden langes suchen, lesen und umsetzen).

        Antworten
  13. Elisabeth

    Oh nein :-( Es hat funktioniert und ich habe eine Datei per Terminal in das Mediacenter kopiert.
    Aber die Datei wird online nicht vollständig (Dateigröße) angezeigt, aber die Dateigröße steigt wenn man das Mediacenter online offen lässt, wenn auch extrem langsam, als würde sie gerade hochgeladen. Aber das beginnt immer wieder neu wenn ich es aufrufe, sie scheint nicht online gespeichert zu sein.
    Dazu kommt das größere Problem: Mein home Verzeichnis lässt sich nicht mehr per Dateimanager öffnen, das Terminal per Strg Alt T auch nicht. Hat jemand eine Idee, was passiert ist? Ich nutze Ubuntu 16.04.

    Antworten
  14. Jörg Kastning Beitragsautor

    Guten Abend,

    mit der in diesem Artikel beschriebenen Anleitung kann das T-Online-Mediencenter in das Linux-Dateisystem eingebunden werden. In ähnlicher Weise lassen sich auch die WebDAV-Verzeichnisse von ownCloud bzw. Sciebo einhängen.

    Die ownCloud-Dokumentation beschreibt die dazu notwendige Vorgehensweise in „Creating WebDAV Mounts on the Linux Command Line“. Auch wenn die Dokumentation in Englisch geschrieben ist, lassen sich die einzelnen Schritte denke ich recht einfach befolgen.

    Viele Grüße
    Jörg

    Antworten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.